Introduction et pseudo language

De Avided.info
Aller à : navigation, rechercher


Introduction

Dans la vie de tous les jours, ils nous arrivent d'indiquer le parcours à un automobiliste ou de donnée une recette de cuisine à un amis. A ces moments, nous fournissons un algorithme à notre interlocuteur.

Un algorithme est la description d'un comportement définit par une suite d'actions ou d'instructions permettant d'atteindre un objectif fixé. Il doit être exprimé en des termes compréhensibles par celui qui doit exécuter ces instruction et doit être précis et non ambigus. Si il est faux, l'objectif ne sera pas atteint et le résultat obtenue sera aléatoire.

Dans notre cas l'algorithmie sera utilisé pour développer des programmes. Un ordinateur est un automate qui ne sait répondre qu'à certains ordres précis

* évaluer une information : une expression
* placer des informations dans un support : la variable
* récupérer une information fournie par l'utilisateur : cette information est placer dans une variable
* afficher une information à l’écran de l'utilisateur : spécifier par une expression

Un langage est nécessaire afin d'exprimer l'algorithme. Il est indépendant des spécificités d'un langage de programmation. Ce langage sera appelé "pseudo code". Il favorise une analyse plus structuré que l'ancienne méthode "organigramme"

Variables

Elle permettent de mémoriser une valeur. Désigné par un nom : l'identificateur

Une variable doit être typé. On indique le type de contenue que la variable hébergera. Le type de la variable catégorise la classe de valeur. Il caractérise les propriétés de la valeur mémorisé.

  • Le glossaire : C'est le recensement des variables utilisé. C'est aussi ici que les variable seront déclarées.

Expression

Constitué d’Opérandes et d’opérateurs.

Opérateurs

Les opérateurs peuvent être :

  • UNAIRE : un seul opérande nécessaire
  • BINAIRE : 2 opérandes nécessaires
    • Arithmétique Unaire :
      +, -
    • Arithmétique Binaire :
      +, -, *, /, ^, div, mod
    • Relation binaire :
      =, #, <, <=, >=, >
    • Composition de condition binaire :
      et, ou
    • comportement logique :
      non

Opérandes

  • Valeur immédiate : littéral numérique ou logique
0 12
faux vrai
  • Valeur nommé
PI
  • Variables

A, FINI

  • expression

Si une opérandes est une expression c'est que nous sommes dans une expression imbriqué. Dans ce cas, on préférera utiliser les parenthèses

X + (A/B)


Actions de bases

Affectation de variable :

  • Valoriser la variable VAR par la valeur 1
VAR <- 2;
  • La valeur peux être une variable.

Dans ce cas le contenue de la variable_valeur sera copié dans la variable cible

VAR_COPIE <- VAR;
  • un calcul
VAR_COPIE <- VAR div 2;
  • Une condition
VAR_COPIE <- VAR < 10;

ou

VAR_COPIE <- ( VAR < 10 ) et ( VAR # 0 );

Entrée / Sortie

Permet de communiquer avec l’extérieur

  • "saisir" ou "lire" = permet de récupérer une information utilisateur
  • "afficher" ou "écrire" = permet d'afficher une information a l'utilisateur
Afficher "indiquer votre age:" 
saisir VARIABLE_AGE;
afficher "votre age est :", VARIABLE_AGE;

Structures de contrôles

Une structure de contrôle est un modèle d’exécution permettant de décrire un comportement type. Seul 3 structures s'avèrent nécessaires:

la séquence

Permet de créer un bloc de code

début "Action1"; "Action2"; "ActionN"; fin;

le choix

permet de décrire l’exécution conditionnel. La condition renvoie une valeur logique VRAI ou FAUX

si "condition" alors
  "CODE"
fin si;

ou (l'alternative)

si "condition" alors
  "CODE1";
sinon
  "CODE2";
fin si;

Les opérateurs

ET FAUX VRAI
FAUX F F
VRAI F V


OU FAUX VRAI
FAUX F V
VRAI V V


NON
FAUX V
VRAI F

Les 2 structures suivantes sont équivalente :

- Toute structure composée de l'opérateur "et" peut être exprimé avec l'opérateur "ou" et vice-versa.

  • Structure 1
si T1 et T2 alors
  ACT1
sinon
  ACT2
fin si;
  • Structure 2
si non t1 ou non t2 alors 
  ACT2
sinon
  ACT1
fin si;


la répétition

Cette structure de contrôle permet de répéter plusieurs fois une même action. On parle de boucle, de structure répétitive ou structure itérative

  • répétition en nombre connu
répéter N fois 
  ACTION
fin répéter;

Dans le cas suivant X est appeler "variable de contrôle". Elle prend la valeur de l’élément en cours de traitement jusqu’à ce qu'il n'y ai plus d’élément. Elle pourra être utilisée dans le code d'action.

pour X dans ensemble faire
  ACTION
fin pour;
    • intervalle

si l'ensemble est un intervalle croissant ou décroissant, il peux être écrit de la manière suivante

pour X dans A/>B faire 
pour X dans A\>B faire
  • répétition en nombre inconnu

"tant que CONDITION " et "répéter / jusqu'à non CONDITION" sont équivalent

tant que Condition faire
  ACTION
fin tant que;

La variante suivante permet d’exécuter au moins une fois le code, vue que la condition est contrôler a la fin

répéter 
  ACTION 
jusqu'à Condition; 

Construction des boucles